Resolved: Sandbox ETA 500 error


I can no request ETAs in the sandbox. it’s been working fine for months… everything is normal when I switch to live keys.

I get an 500 error response with the body:

Empty input () at line 1, column 1 [parse.c:988] in ’ is coming soon Hv logo retina

is a totally awesome idea still being worked on.

Check back later.

here is the raw payload:

User-Agent: stuart-client-csharp/1.3.1
Authorization: Bearer eyJhbGciOiJFUzI1NiJ9.eyJpc3MiOiJzdHVhcnQtYXBpIiwiaWF0IjoxNTk4NjEyNDAwLCJqdGkiOiIzNjNlYjRlNy1hMjUyLTQ3ZDktOWViZi1hZWFkN2QyNWUzZTgiLCJzcnQ6ZW52aXJvbm1lbnRzIjpbInNhbmRib3giXX0.3Tt2tM3W5TURywMVWR6H2EafVrJ_Z_jy24uvZaEkCY8f6hUATxciWt7eIus5J1Vv2VDYrrRducAsYeOmUtdJ6g
Content-Type: application/json; charset=utf-8
Content-Length: 364
Expect: 100-continue

{“job”:{“pickups”:[{“address”:“11 Horton Ave, London NW2 2RY, UK”,“contact”:{“firstname”:“Nadav”,“lastname”:“Drewe”,“phone”:“07397 011 706",“email”:"”}}],“dropoffs”:[{“package_type”:“small”,“address”:“23a chalk farm road London NW1 8AG”,“contact”:{“firstname”:“Nadav”,“lastname”:“Drewe”,“phone”:“07397 011 706",“email”:"”}}]}}

Hi @nadavdrewe,

Thank you for bringing this to our attention, we will report this issue internally and keep you posted on any updates.

Thanks. I’ve just created a completely fresh dev account in your sandbox with a new email address, and it’s throwing exactly the same error…

HI Lauren,

Is there any update on this? I need to tell my head of department why we can’t demo in the Stuart sandbox… is this a known issue?

Many thanks


Lol, I can’t even get an OAUTH token from the sandbox now… again live remains fine… it returns 401 despite being supplied the correct id/secret… is everything okay over there? :slight_smile:

Hello Nadav,

The Get ETA in sandbox issue is a known issue we are actively working on solving.

However I was able to get an oauth token from sandbox :thinking: do you have any other information on this issue on your side ?

I’m also having trouble with OAUTH.
Getting a 500 error back when sending this request:

curl -X POST \ \
  -H 'Content-Type: application/json' \
  -H 'cache-control: no-cache' \
  -d '{
	"client_id": "MY_CLIENT_ID",
	"client_secret": "MY_CLIENT_SECRET",
	"scope": "api",
	"grant_type": "client_credentials"

Response Headers:

X-Request-Id b1fe1258-c621-44ca-8501-6da1ff728343
X-MinuteRateLimit-Limit 500
X-MinuteRateLimit-Remaining 499
X-DailyRateLimit-Identifier ratelimit:
X-DailyRateLimit-Limit 43200
X-MinuteRateLimit-Identifier ratelimit:
X-DailyRateLimit-Remaining 43199
X-Runtime 0.079384

Thank you Luis,
I am also able to reproduce the error now and raising the problem internally. I will come back to you as soon as I have more information.

1 Like

We had an issue with the latest deploy in sandbox. It should be back in a normal state now and you should be able to request new token.

The Get ETA issue is sill under examination though. Will come back to you when this one is fixed also.

Hello @nadavdrewe,

The 500 error on the ETA endpoint is now resolved, thank you for raising this issue and let us know if you notice any other such issues in the future.

Hi in it does seem to be resolved, But it seems to return no drivers no matter what destination and pick up I choose…?

Also… I can’t add a card in the sandbox. It says ‘invalid card’, despite the fact I’m actively using the card right now…

Hi @nadavdrewe,

The ETA is based on the fleet availability depending on the area, unfortunately it seems that the way that our driver bots are spawned may be contributing to the fact that no drivers appear to be available when calling the ETA endpoint.

It is possible to still create a job even if the eta endpoint indicates that there are no drivers available (even in Production) since the state of the fleet is ever changing and jobs can also be scheduled into the future. Feel free to go ahead and try creating jobs, they should still get assigned.

We are looking into this issue with this Sandbox ETA endpoint showing ‘NO_DRIVER_AVAILABLE’ and apologise again for the inconvenience. We will keep you posted on any updates.

On the credit card issue, I have set your account to no longer require the credit card for this Sandbox account. You shouldn’t receive any errors related to this now.

Hi Lauren,

Thanks for the assist, but I’m still getting CREDIT_CARD_NOT_FOUND using the (this email) login sandbox account…

Hi @nadavdrewe,

Could you try removing your credit card details from your dashboard settings?

Hi Lauren,

Have removed the single card that was there.

Still the same I’m afraid.

Is this error referring to your Sandbox or Production account?

You can find more details on adding credit card details to a Sandbox account here including some mock credentials, note to not use American Express. Example credentials that should work are `4111111111111111, 11/12, 123, tester’

The whole thread is sandbox: I appreciate you’re probably dealing with numerous different cases and clients so it’s hard to keep track.

Thank you I will try that now.

Hi Lauren,

Sandbox was working yesterday and I was able to create orders - it’s now broken again.


See error below: