Locations unavailable?

I am trying to get the zone info for southampton and portsmouth.
Last week that was working fine, but now I get the error ‘map_not_found’. Other areas, such as bristol, or coventry work fine.
I also can’t request job prices for these areas. Any ideas?

Hello @andy,

Thank you for reaching out.

We will investigate why you may have experienced this behaviour and will come back to you asap.

In the meantime do tell us if you notice any behaviour change.

Hi @andy,

To help troubleshoot this issue can you please provide a list of areas you tried and received error message ‘map_not_found’ for?

Also, can you please confirm the API endpoint used?

Many thanks,

Hi @Daniel
The error is “{“error”:“MAP_NOT_FOUND”,“message”:“No geojson available for picking in southampton”}”

I have tried southampton, portsmouth, bristol, coventry. The endpoint is the Open Zone e.g. https://api.sandbox.stuart.com/v2/areas/southampon?type=picking

The Bristol response is:
"{“type”:“FeatureCollection”,“features”:[{“type”:“Feature”,“properties”:{“name”:“bristol operational area”,“zone”:“bristol”},“geometry”:{“coordinates”:[[[-2.514577,51.508358],[-2.529676,51.527568],[-2.548172,51.546149],[-2.552855,51.551181],…

I have also tried it with the price endpoint and get a similar error:
{“job”:{“pickups”:[{“address”:“SO19 4AA”}],“dropoffs”:[{“package_type”:“small”,“address”:“SO17 2GD”},{“package_type”:“small”,“address”:“SO18 6TG”},{“package_type”:“small”,“address”:“SO18 1HZ”},{“package_type”:“small”,“address”:“SO19 4AA”}]}}-{“error”:“UNKNOWN”,“message”:“No geojson available for southampton”}

Hi @andy,

Thank you for raising the issue, I can confirm this is being currently looked into and I will have an update for you as soon as possible.

Thank you for your patience.

Hi @andy,

Thank you for your patience, I have tested and can confirm the misaligned map of Southampton in sandbox has been resolved.

Portsmouth’s map will be updated shortly.

Kind regards

Hi Daniel,

I have now tried running the job quote endpoint and a similar error is happening…
“{“error”:“UNKNOWN”,“message”:“No geojson available for southampton”}”
is what is returned. The locations are definitely in the area as that is initially checked in the first API call to get the area info.

Please can you help?


Hi @andy,

Thank you for raising this issue.

I’ve investigated the issue and a fix will be implemented soon.

The uploading of the map needs to be done during less busy times and will be applied EOD, so please try again tomorrow.

Many thanks,